Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9340 closed bug (duplicate)

Unable to pass payload containing ?? via ajax call

Reported by: jabley Owned by:
Priority: low Milestone: 1.next
Component: ajax Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery 1.5.2

Firefox 4.0.1, Mac OSX Snow Leopard Firefox 3.6, Windows XP

Attempting to pass a JSON payload via AJAX which contains the string ?? gets treated as a JSONP request and the ajax error function is called, stating that

"jQuery152011057530349834899_1305758039649 was not called"

See http://jsfiddle.net/FtX2g/

and

https://gist.github.com/979756

On IRC, I was advised to use the Javascript escape function on the client, and decode server-side. This feels clunky and also has problems with codepoints unsuitable for transmission in a Latin-1 encoding.

If you change the linked jsfiddle test to use jQuery 1.6, the test passes.

Any plans for further 1.5.x releases, or should I begin to upgrade to 1.6.x?

Change History (3)

comment:1 Changed 9 years ago by Rick Waldron

Component: unfiledajax
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by Rick Waldron

Duplicate of #8417.

comment:3 Changed 9 years ago by jabley

Actually, if I remove the dataType: "json" option, it works fine.

http://jsfiddle.net/3J5sv/

Note: See TracTickets for help on using tickets.