Bug Tracker

Opened 8 years ago

Closed 8 years ago

#9321 closed bug (invalid)

$(window).resize() in iframe causing problems in IE 8/9

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: 1.next
Component: event Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

I upgraded from version 1.5.1 to 1.5.2 and noticed that in IE8/9, the $(window).resize() isn't working correctly. It works fine in Chrome 10/11/12 and firefox 3.5/4.

1.6.1 also doesn't work.

I resize a div that's in an iframe, and if it becomes bigger than the screen, the scrollbars show up, which is good. The problem is the scrollbars are telling IE8/9 that the window was resized again, thus calling the window.resize handler a second time!

Change History (2)

comment:1 Changed 8 years ago by timmywil

Component: unfiledevent
Owner: set to anonymous
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.