Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9299 closed bug (duplicate)

onkeypress attribute returns wrong type in ie6/7

Reported by: wheresrhys Owned by:
Priority: low Milestone: 1.6.2
Component: attributes Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

returns a function not the original string http://jsfiddle.net/wheresrhys/nhExE/1/

(NOTE: although not in the release notes I noticed that this is broken in all browsers in v1.5 - 1.5.2, but fixed for all but ie6&7 in v1.6)

Change History (3)

comment:1 Changed 8 years ago by wheresrhys

Also, if you replace attr() with prop(), it returns a function in all browsers. ON jsfiddel v.1.6.1 is not available, but I'll try testing upgrading to 1.6.1 locally

comment:2 Changed 8 years ago by timmywil

Component: unfiledattributes
Milestone: 1.next1.6.2
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:3 Changed 8 years ago by timmywil

Duplicate of #9298.

Note: See TracTickets for help on using tickets.