Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#9293 closed bug (invalid)

nth-child error on google chrome

Reported by: nicola.gnecchi@… Owned by: nicola.gnecchi@…
Priority: low Milestone: 1.next
Component: selector Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

nth-child nested selector doesn't seem to work on chrome. Instead of opening "openLi"(openLi is an integer) element of the DOM, it opens the "opelLi+2" element, even if the alert of ".vertical-menu > li:nth-child("+openLi+") > ul").show()" shows its correctness. This script works perfectly on IE7,IE8,FIREFOX.. This is the script code:

$(function() {
	var openLi = $.cookie("open-menu-item");
	if(openLi != null) {
		$(".vertical-menu > li:nth-child("+openLi+") > ul").show();
	}
});

Html code passed w3 validation.. Using "eq" instead of "nth-child" with "openLi - 1" will work.

Change History (3)

comment:1 Changed 9 years ago by timmywil

Component: unfiledselector
Owner: set to nicola.gnecchi@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 6 years ago by anonymous

find that this is working in chrome, however the nth-last-child still gives me issues.

Note: See TracTickets for help on using tickets.