Bug Tracker

Opened 8 years ago

Closed 8 years ago

#9271 closed bug (invalid)

jquery1.6 bug

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: 1.next
Component: selector Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

var ct = $("<ct></ct>"); ct.append("<ca></ca>"); alert(ct.children().length);it will alert 2 with IE8, but chrome and firefox alert 1

var ct = $("<ct></ct>"); $("<ca></ca>").appendTo(ct); alert(ct.children().length);it will alert 1 result, it's right

Change History (2)

comment:1 Changed 8 years ago by addyosmani

Component: unfiledselector
Owner: set to anonymous
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a *complete* reduced test case on http://jsFiddle.net that reproduces the issue experienced to help us assess your ticket!

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.