Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9259 closed bug (duplicate)

1.6 breaks my code

Reported by: chuck@… Owned by: chuck@…
Priority: low Milestone: 1.next
Component: attributes Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

JQuery 1.3 - 1.5.2 seems to run this code ok. 1.6 does not.

In my app I dynamically update the status of two radio buttons that indicate the direction off a "pin".

<div id="pinio"> <input type="radio" name="I_O" value="0" onclick="editPin('I_O',0)"> In<br />

<input type="radio" name="I_O" value="1" onclick="editPin('I_O',1)"> Out<br /><br/> </div>

Whenever a new pin is selected the following jquery updates the radio buttons to indicate which direction that pin in pointing.

var $radios = $('#pinForm input[name="I_O"]:radio'); $radios.filter('[value='+pinsMainRaph[i].PT_io_type+']').attr('checked',true);

pinsMainRaph[i].PT_io_type will be either a "0" or a "1" depending on pin direction.

Works great in earlier versions. In 1.6 it sets the radio buttons correctly the first time it runs, but not at all after that. No errors in Chrome, no clue as to why. Tried several variations and still no workie. Happy to answer any questions you might have.

Change History (4)

comment:1 Changed 9 years ago by ajpiano

Owner: set to chuck@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket!

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, we've created this boilerplate: http://jsfiddle.net/rwaldron/da3nM/ Open the link and click to "Fork" in the top menu.

comment:2 Changed 9 years ago by anonymous

Here is a JsFiddle Demo of the issue. Instruction in Java comments http://jsfiddle.net/RUQVt/2/

comment:3 Changed 9 years ago by timmywil

Component: unfiledattributes
Priority: undecidedlow
Resolution: duplicate
Status: pendingclosed

comment:4 Changed 9 years ago by timmywil

Duplicate of #9191.

Note: See TracTickets for help on using tickets.