Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9240 closed bug (invalid)

IE 9 issue with .replaceWith method

Reported by: vijayaneraye Owned by: vijayaneraye
Priority: undecided Milestone: 1.next
Component: manipulation Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

Hi All,

Here is the div with span

<ul class="tabs visibility-toggle">

<li class="tab"><a href="#" id="cart-toggle"><span>&nbsp;Hide Cart</span></a></li>

</ul>

I want to change the span text, following is the code am using to change the text.But am running through SCRIPT5007: 'Unable to get value of the property 'update': object is null or undefined ' for following line on IE9 $$('#cart-toggle span')[0].replaceWith('Show Cart');

For other browser its working fine.

My function is here

showChart: function() {

$('cart-options').removeClassName('hidden').addClassName('show');

$$('#cart-toggle span')[0].replaceWith('Show Cart'); $('cart-hdr').show(); $('cart-wrapper').show(); Cookie.set("portfolioCartDisplay", "show");

}

Could you please help me to get it done.

Change History (3)

comment:1 Changed 8 years ago by timmywil

Component: unfiledmanipulation
Owner: set to vijayaneraye
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by anonymous

having the same problem on ie9 only using the replaceWith function

comment:3 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.