Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9230 closed bug (duplicate)

Error with .html()

Reported by: MrMamen Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

I get an error on line 600 only in IE, when trying to set html on a object.

The code which works in earlier versions of jQuery (and other browsers) is like this: $dialogContent.html(ajaxFetchedContent);

ajaxFetchedContent contains <script>-tags, and seem to be the reason for failing. the script are valid javascript (as they work on pages where they are not included dynamically, and in other browsers), but when commenting htem away I get no such error.

Change History (3)

comment:1 Changed 10 years ago by MrMamen

After further investigation, this only failes if html-comments are present inside script block. Like this:

<script type="text/javascript">
<!--
function foo() {
  //bar
}
// -->
</script>

comment:2 Changed 10 years ago by jaubourg

Resolution: duplicate
Status: newclosed

comment:3 Changed 10 years ago by jaubourg

Duplicate of #9221.

Note: See TracTickets for help on using tickets.