Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#9192 closed bug (invalid)

internet explorer :checked value problem

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: 1.next
Component: attributes Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

dil=$("#elementh_id:checked").val();

i take this error: "object does not support this property or method"

for ie6, ie7, ie8

it is working well with ie9

Change History (3)

comment:1 Changed 9 years ago by timmywil

Component: unfiledattributes
Owner: set to anonymous
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 6 years ago by anonymous

Para verificar se um checkbox está checado no IE7 em diante faça:

[code] $(document).on('click','#mostrar', function(){

if ($(this).is(':checked')) {

$(".aeb").show();

} else{

$(".aeb").hide();

}

}); code

funciona em todos os navegadores...

Note: See TracTickets for help on using tickets.