Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9189 closed feature (duplicate)

Add helper functions .checked() and .disabled()

Reported by: Ariel <asjquery@…> Owned by:
Priority: low Milestone: 1.next
Component: attributes Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Rick Waldron)

Per what Dave Methvin wrote in I am posting this as a reminder.

Add helper functions .checked() and .disabled() which manipulate or return their properties (just like val()).

I suspect that those two are the most frequently used attributes/properties, and adding those helpers would probably negate the majority of the confusion regarding properties.

Also there may be a speed increase since they can directly go to the dom .checked or .disabled for the element.

Change History (4)

comment:1 Changed 9 years ago by timmywil

Component: unfiledattributes
Type: enhancementfeature

comment:2 Changed 9 years ago by Rick Waldron

Description: modified (diff)

Is this almost a duplicate of #7441 ?

comment:3 Changed 9 years ago by timmywil

Priority: undecidedlow
Resolution: duplicate
Status: newclosed

Close enough I think. We only need one ticket for these methods.

comment:4 Changed 9 years ago by timmywil

Duplicate of #7441.

Note: See TracTickets for help on using tickets.