Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#9171 closed bug (duplicate)

1.6 attribute and selector Inconsistant in IE7,8

Reported by: anonymous Owned by: timmywil
Priority: low Milestone:
Component: selector Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

Try this example http://jsfiddle.net/timmywil/5DTfu/2/ in IE7 or 8 and FF, the value of .attr() and attribute selector are inconsistant between the browsers(value in IE7,8 are different from FF).

Tried in jQuery edge as well.

Change History (6)

comment:1 Changed 8 years ago by timmywil

Component: unfiledselector
Milestone: 1.next1.7
Priority: undecidedlow
Status: newopen

Sizzle has the same issue, but the attr problem has been fixed for 1.6.1. Changeset 18b1cf2942cc082c1c97a2ac9bc33ad77f42d775

Leaving this open as a selector bug for 1.7 when sizzle will be aligned with attr.

comment:2 Changed 8 years ago by dmethvin

Owner: set to timmywil
Status: openassigned

comment:3 Changed 8 years ago by timmywil

Resolution: duplicate
Status: assignedclosed

comment:4 Changed 8 years ago by timmywil

Duplicate of #7128.

comment:5 Changed 7 years ago by dmethvin

Milestone: 1.7

comment:6 Changed 7 years ago by Shawn

Try this one http://jsfiddle.net/5DTfu/21/ For the selector, result in IE8 is different from FF and Chrome.

Note: See TracTickets for help on using tickets.