Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9165 closed bug (invalid)

attribute selector with accesskey fails

Reported by: maggus.staab@… Owned by:
Priority: low Milestone: 1.next
Component: selector Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

the selector

$("input[accesskey=a]")

leads to "uncaught exception: Syntax error, unrecognized expression: [accesskey=a]" in ff4

Change History (3)

comment:1 Changed 8 years ago by Rick Waldron

Component: unfiledselector
Priority: undecidedlow
Resolution: invalid
Status: newclosed

attribute selectors require quotes around the attribute value

comment:2 Changed 8 years ago by maggus.staab@…

the problem also occurs when using quotes

[accesskey='a']

even when using double quotes

[accesskey="a"]

comment:3 Changed 8 years ago by timmywil

I created this fiddle, but was unable to reproduce: http://jsfiddle.net/timmywil/hB5Ut/

Note: See TracTickets for help on using tickets.