Skip to main content

Bug Tracker

Side navigation

#9151 closed bug (invalid)

Opened May 06, 2011 05:24PM UTC

Closed May 08, 2011 04:50PM UTC

Simple toggleClass() is not working correctly

Reported by: Owned by:
Priority: low Milestone:
Component: attributes Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Please see isolated bug

Click "update"

now user should be able to click and choose all tags,

Now "save"

And try to update again

expected result = its should work again

but it doesn't work till its

"saved again"

Tried multiple versions of jQuery.

I tried to debugg with console, and narrowed it down to the toggleClass() method.


Attachments (0)
Change History (5)

Changed May 06, 2011 06:10PM UTC by timmywil comment:1

component: unfiledattributes
owner: →
priority: undecidedlow
status: newpending

It works for me, which browser are you using?

Changed May 06, 2011 06:13PM UTC by anonymous comment:2

Replying to [comment:1 timmywil]:

It works for me, which browser are you using?

Google chrome on mac

Changed May 06, 2011 06:38PM UTC by timmywil comment:3

As am I. I've created a reduced test case because maybe I'm missing the problem.

Please update mine to show the breakage if you could.

Changed May 08, 2011 03:52PM UTC by anonymous comment:4

@ timmywil Thanks, i narrowed down the problem to a misuse of a closure.

As in my case it captured the state of the element without the class.

Anyway, thanks.

I think you can close this bug.

Thanks again.

Changed May 08, 2011 04:50PM UTC by timmywil comment:5

resolution: → invalid
status: pendingclosed

Thank you for looking into it.