Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#9143 closed bug (duplicate)

Wrong behavior for "mouseenter" and "mouseleave" with "live"

Reported by: denis@… Owned by:
Priority: high Milestone: 1.next
Component: event Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

e.type returns "mouseover" when "mouseenter" fires and "mouseout" when "mouseleave" fires. See an example:

$('ul li').live('mouseenter mouseleave', function (e) {

var target = e.target ? e.target : event.srcElement;

console.log(e.type);

...

});

it looks like "mouseenter" behaves like "mouseover" and "mouseleave" like "mouseout".

Change History (2)

comment:1 Changed 8 years ago by timmywil

Component: unfiledevent
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by timmywil

Duplicate of #9069.

Note: See TracTickets for help on using tickets.