Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9142 closed bug (worksforme)

animate loose fluidity/performance after version 1.4.4 in FF

Reported by: _devyan_ Owned by: _devyan_
Priority: low Milestone: 1.next
Component: effects Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

I've seen that since jQuery 1.5 the animate() performance decrease.

A simple $('div.banner-scroll').animate({left:0}, 10000); has a good looking fluidity in jQuery 1.4.4 but lags a lot in newer versions.

The backgoundPosition animation doesn't seems to work either. The result in 1.5.2 and 1.6 is the same as .css(backgroundPosition)

Change History (8)

comment:1 Changed 8 years ago by addyosmani

Component: unfiledeffects
Owner: set to _devyan_
Priority: undecidedlow
Status: newpending

Thanks for submitting a ticket to the jQuery Project. Could you submit a reduced test case that reproduces the mentioned visible decrease in animation performance on http://jsFiddle.net so we can assist further?

comment:2 Changed 8 years ago by _devyan_

Status: pendingnew

Thanks, here you can find a sample : http://jsfiddle.net/5xN32/.

There is less lags in jsFiddle maybe because I also use jQuery-ui (for datepicking, drag'n'drops & resizing elements)

(in my webapp, the moving steps with the same duration calculation is about 10px with v1.6 in the animation scrolling)

devyan. P.S. : i use FF 3.5.7

comment:3 Changed 8 years ago by _devyan_

Note that I also have lags when playing the samples from this page http://api.jquery.com/animate...

devyan.

comment:4 Changed 8 years ago by lrbabe

Just out of curiosity, are you seeing similar issues in Internet Explorer? And Firefox4?

comment:5 Changed 8 years ago by devyan

I've made some tests under IE7 (for your curiosity ... & mine ;D) and found that there is a problem with the colorbox library (an initializing script doesn't seems to stop with jQuery 1.6)

I've posted a message to the colorbox team...

More details next time.

devyan

comment:6 Changed 8 years ago by addyosmani

Resolution: worksforme
Status: newclosed

I've updated your original testcase to use our edge version of jQuery (currently 1.6.1) and the animation appears to be fluid on my system, across FireFox, Chrome and Opera. Please see here: http://jsfiddle.net/5xN32/3/. I also don't experience any lags running the examples on http://api.jquery.com/animate in these browsers either.

comment:7 Changed 8 years ago by _devyan_

Hi,

I think I finally found the "real" source of the problem ...

I also use the "jQuery UI.Layout" plugin and :

  • with jQuery 1.4.4 the layout resize event is fired once
  • with jQuery 1.6 (and 1.6.1) the ui.layout onresize event is fired and fired without stopping.

This abnormal activity use CPU resources and I have lags in my multi-messages marquee scrolling

comment:8 in reply to:  5 Changed 8 years ago by _devyan_

Replying to devyan:

I've made some tests under IE7 (for your curiosity ... & mine ;D) and found that there is a problem with the colorbox library (an initializing script doesn't seems to stop with jQuery 1.6)

I've posted a message to the colorbox team...

More details next time.

devyan

I've had an answer from the Colorbox team concerning IE7 :

Use jQuery 1.5.2 or jQuery 1.6.1 when it comes out (the release
candidate is already out).  There was a bug in jQuery 1.6.0 that
caused this to happen for IE6 and 7.  Here is the relevant ticket:

http://bugs.jquery.com/ticket/9072
Note: See TracTickets for help on using tickets.