Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9135 closed bug (invalid)

latest jquery date-input plugin not work with jquery 1.5.1

Reported by: anonymous Owned by:
Priority: low Milestone: 1.next
Component: misc Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have tried to use date-input with jQuery 1.4.4, its working fine.

But when I use jQuery 1.5.1, even 1.6, it stops working.

It seems the date-input plugin hasn't been updated for a while.

Thanks Chao

Change History (2)

comment:1 Changed 9 years ago by addyosmani

Component: unfiledmisc
Priority: undecidedlow
Resolution: invalid
Status: newclosed

Thanks for submitting a ticket to the jQuery Project! Unfortunately, we are unable to assist with debugging issues related to third party plugins. We instead recommend that you get in touch with the plugin author directly regarding the issues you're experiencing. You can do this via their official project site, repository or dedicated issue tracker.

comment:2 in reply to:  1 Changed 9 years ago by JavierCaptain

Hi,

is a Date-Input bug. You've to change plugin's line 127 and 134. The problem is the missing char(') for the attribute filter that is not validated by regex of jquery version 1.5.

example line 127: original: $("td[date=" + this.dateToString(new Date()) + "]", this.tbody).addClass("today");

correct: $("td[date='" + this.dateToString(new Date()) + "']", this.tbody).addClass("today");

Note: See TracTickets for help on using tickets.