Bug Tracker

Opened 8 years ago

Closed 8 years ago

#9131 closed bug (invalid)

the :eq selector (and others) doesnt return the same thing depending of filters

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: 1.next
Component: selector Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

On a simple html table, these 2 selectors doesnt return the same column index!

  • $("#table tr td:eq(8)")
  • $("#table tr:first td:eq(8)")

the first one will return the 8th column

the second one will return the 9th column

Change History (3)

comment:1 Changed 8 years ago by timmywil

Component: unfiledselector
Owner: set to anonymous
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by anonymous

Status: pendingnew

well, i've found where my error was. Its because i was using grouping cell (colspan) and i wasnt exluding them in the query so i had weird results.

sorry for this one!

comment:3 Changed 8 years ago by timmywil

Resolution: invalid
Status: newclosed

Thanks for looking into it.

Note: See TracTickets for help on using tickets.