Bug Tracker

Opened 9 years ago

Closed 9 years ago

#9119 closed bug (invalid)

wrap & unwrap bug

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: 1.next
Component: manipulation Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

wrap & unwrap function have some bugs when wrap html is more complex than usual such as: "<div style'background-color:#FFEECC; text-align: right'></div>" or "<table><tr><td></td><td>&nbsp;</td><tr></table>" I think this caused by using regular javascript replace method and may have some fuzzy thing between normal text and regexp

Change History (2)

comment:1 Changed 9 years ago by addyosmani

Component: unfiledmanipulation
Owner: set to anonymous
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsFiddle.net that reproduces the issue experienced to help us assess your ticket!

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.