Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9118 closed bug (duplicate)

jQuery 1.6 : Animations now broken in new version!

Reported by: [email protected] Owned by:
Priority: high Milestone: 1.next
Component: effects Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

I upgraded to jQuery 1.6 this morning and now a lot of the animations I spent so long fine tuning in my app are now failing. Here is an example of one. Notice how the 1.5 animation keeps the box centered, but on the 1.6 animation the something goes wrong.

I have narrowed it down to something to do with the opacity being involved in the animation. If I remove the opacity it works fine...

Example with JQ 1.5: http://jsfiddle.net/LJZ54/3/

Example with JQ 1.6: http://jsfiddle.net/LJZ54/4/

Example with JQ 1.6 (no opacity): http://jsfiddle.net/LJZ54/5/

Change History (3)

comment:1 Changed 10 years ago by timmywil

Component: unfiledeffects
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by timmywil

Duplicate of #9074.

comment:3 Changed 10 years ago by [email protected]

For some reason, if you make opacity the first in your list of animated properties, it fixes the problem.

http://jsfiddle.net/nicktheandroid/LJZ54/57/

Note: See TracTickets for help on using tickets.