Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9110 closed bug (duplicate)

jQuery.support.appendCheck causes infinite loop in Windows Gadgets

Reported by: mike@… Owned by:
Priority: high Milestone: 1.next
Component: manipulation Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

I know you guys don't support Windows 7 Gadgets but I thought I would give you a heads up in case this is something you want to document.

I've found calling $(element).append(elements) in code that runs in Windows 7 sidebar gadgets can cause the "clean" function in jQuery core to loop infinitely. The section where it gets stuck in clean is:

        // Resets defaultChecked for any radios and checkboxes
        // about to be appended to the DOM in IE 6/7 (#8060)
        var len;
        if (!jQuery.support.appendChecked) {
          if (elem[0] && typeof (len = elem.length) === "number") {
            for (i = 0; i < len; i++) {
              findInputs(elem[i]);
            }
          } else {
            findInputs(elem);
          }
        }

I was able to fix my problem by adding the following to my script:

jQuery.support.appendChecked = true;

Not sure why this works but it fixed my problem.

  • Mike

Change History (2)

comment:1 Changed 9 years ago by timmywil

Component: unfiledmanipulation
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by timmywil

Duplicate of #9072.

Note: See TracTickets for help on using tickets.