Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#9083 closed bug (invalid)

Uncaught TypeError: Object #<HTMLDocument> has no method 'getAttribute'

Reported by: quaff Owned by:
Priority: low Milestone: 1.next
Component: attributes Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

var tagName = $(container).attr('tagName'); throws exception when container is document it break compatibility with previous version,it must return undefined

tested in chrome 12.0.742.16 dev-m

Change History (2)

comment:1 Changed 8 years ago by timmywil

Component: unfiledattributes
Priority: undecidedlow
Resolution: invalid
Status: newclosed

This is expected behavior as of jQuery 1.6. tagName is a property that should either be checked by doing elem.tagName or using the new http://api.jquery.com/prop method. For more information, see the release notes.

comment:2 Changed 8 years ago by timmywil

#9084 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.