Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9054 closed bug (duplicate)

jQuery failed to trigger the ready callback function on BlackBerry 4.6 web Browser

Reported by: Raymond Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

To fix this I had to modify jQuery to check for a if a null value as returned from the getComputedStyle(div, null) method.

if ( document.defaultView && document.defaultView.getComputedStyle ) {

div.style.width = "1px"; div.style.marginRight = "0"; fix for blackberry 4.6

var cs = document.defaultView.getComputedStyle(div, null)jQuery.support.reliableMarginRight = ( parseInt(cs.marginRight, 10)
{};
0 ) === 0;

}

Change History (3)

comment:1 Changed 9 years ago by Raymond

The above code was not properly formatted when this bug was created.

Here's a copy of the fix on jsFiddle - http://jsfiddle.net/9sDSf/

comment:2 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:3 Changed 9 years ago by dmethvin

Duplicate of #8763.

Note: See TracTickets for help on using tickets.