Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9049 closed bug (duplicate)

.filter is searching children in IE when html5 tags are used

Reported by: jessedpate Owned by:
Priority: high Milestone: 1.next
Component: core Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

In internet explorer, the .filter method is incorrectly iterating over second level child nodes when html5 elements are used. This behaves as expected in firefox, chrome, and safari.

$("<body> <section class='first'> <div class='second'></div></section> </body>").filter(function() { console.log($(this).attr('class')); return $(this).is('.first') });

Expected result: 'First'

Actual Result: 'First' "Second'

Change History (2)

comment:1 Changed 5 years ago by timmywil

  • Component changed from unfiled to core
  • Priority changed from undecided to high
  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed 5 years ago by timmywil

Duplicate of #6485.

Note: See TracTickets for help on using tickets.