Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9014 closed bug (duplicate)

Some attribute selectors with brackets don't work in IE7

Reported by: Stephan.Gheorghiu@… Owned by: Stephan.Gheorghiu@…
Priority: high Milestone: 1.next
Component: selector Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Selectors such as input[name="field[0]"] do not work in Internet Explorer 7 (IE8, IE9 and the rest of browser families are ok). Escaping with backslashes doesn't help either.

Change History (5)

comment:1 Changed 5 years ago by timmywil

  • Component changed from unfiled to selector
  • Owner set to Stephan.Gheorghiu@…
  • Priority changed from undecided to low
  • Status changed from new to pending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsFiddle.net that reproduces the issue experienced to help us assess your ticket. Additionally, test against the jQuery (edge) version to ensure the issue still exists.

I've created this test case, but was unable to reproduce the issue.

comment:2 Changed 5 years ago by Stefan Gheorghiu <Stefan.Gheorghiu@…>

Here is the test case: http://jsfiddle.net/SYxVM/2/ It is only reproducible for 1.4.4 and isn't for other versions, including older ones.

comment:3 Changed 5 years ago by timmywil

  • Priority changed from low to high
  • Status changed from pending to open

comment:4 Changed 5 years ago by john

  • Resolution set to duplicate
  • Status changed from open to closed

comment:5 Changed 5 years ago by john

Duplicate of #7596.

Note: See TracTickets for help on using tickets.