Bug Tracker

Opened 8 years ago

Closed 8 years ago

#8965 closed bug (invalid)

$().after().end() differences between 1.3.2 and 1.5.2

Reported by: fly8559@… Owned by: fly8559@…
Priority: low Milestone: 1.next
Component: manipulation Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

<div id="pnode"><div id="fcnode"></div></div>

$(document).ready(function() {

$('#pnode').find('#sconde').after('<b>hello</b>').end().find('#fcnode').append('<b>1 </b>'); $('#pnode').find('#fcnode').append('<b>2</b>').end().find('#sconde').after('<b>hello</b>');

});

1.3.2 result : 1 2 1.5.2 result : 2

Change History (4)

comment:1 Changed 8 years ago by addyosmani

Component: unfiledmanipulation
Owner: set to fly8559@…
Priority: undecidedlow
Status: newpending

Thanks for submitting a ticket to the jQuery Project. I've just attempted to create a test case out of the code you supplied but it appears to be incomplete. Could you please supply us with a reduced test case on http://jsfiddle.net which reproduces the issue you're experiencing. Additionally, please test against jQuery-Git (edge) to see if the issue persists.

comment:2 Changed 8 years ago by addyosmani

Summary: $().after().end() differences between 1.3.2 and 1.3.5$().after().end() differences between 1.3.2 and 1.5.2

comment:3 Changed 8 years ago by anonymous

1.5.2 http://jsfiddle.net/mCnPz/1/ 1.3.2 http://jsfiddle.net/mCnPz/2/

<div id="parent"><div id="child"></div></div> $('#parent').find('#notExists').after().end().find('#child').append('<b>hello</b>');

When I use 1.5.2, the not exists element .after().end() can't return the correct jQuery Object $('#parent') like 1.3.2. it's result is blank but is 'hello' in 1.3.2.

comment:4 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.