Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8960 closed bug (duplicate)

attribute selector not working for IE 8 option selected attribute after AJAX requests

Reported by: NaZaf Owned by:
Priority: high Milestone: 1.next
Component: selector Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

$("option [selected]") When I load html content using AJAX that includes a selected option, the attribute selector does not work.

For example

<option selected='selected'>text</option>

Now if I use

$("option[selected]") or $("option [selected]")

In IE8, I get empty result, but it works well in FireFox.

Change History (3)

comment:1 Changed 9 years ago by anonymous

Here is a test case:

http://jsfiddle.net/kR2ks/1/

comment:2 Changed 9 years ago by timmywil

Component: unfiledselector
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:3 Changed 9 years ago by timmywil

Duplicate of #7128.

Note: See TracTickets for help on using tickets.