Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8946 closed bug (invalid)

FadeIn is not working while fading in "details" element with HTML content

Reported by: zygimantas@… Owned by:
Priority: low Milestone: 1.next
Component: effects Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

Demonstration is here: http://jsbin.com/okosa3/2

Change History (6)

comment:1 Changed 10 years ago by anonymous

Even more simplified example: http://jsbin.com/okosa3/4

comment:2 Changed 10 years ago by zygimantas@…

Details in inline element in HTML5. Maybe it is expected result. Please delete the ticket in this case.

comment:3 Changed 10 years ago by timmywil

Component: unfiledeffects
Priority: undecidedlow
Resolution: invalid
Status: newclosed

The spec for the details tag has changed fairly recently and will soon be implemented as a dropdown widget in all browsers supporting HTML5.

comment:4 Changed 10 years ago by Rick Waldron

I'm getting the correct, expected behaviour - which browser are you having issues in (just for record)?

comment:5 in reply to:  4 Changed 10 years ago by zygimantas@…

Replying to rwaldron:

I'm getting the correct, expected behaviour - which browser are you having issues in (just for record)?

I have been seeing this behavior in Safari 5.0.5 and Firefox 4. I have found, that these browsers understand "details" element as inline (according to specs, it should be display:block). After adding details{display:block} to CSS, the problem is solved.

As I understand, it is not jQuery problems, it is browsers' fault they think new HTML5 elements are inline.

comment:6 Changed 10 years ago by ajpiano

Yeah, a big part of Using HTML5 Now is to make sure to set new elements to be block in your css reset or whatnot.

article, aside, details, figcaption, figure,
footer, header, hgroup, menu, nav, section {
  display: block;
}
Note: See TracTickets for help on using tickets.