Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#8931 closed bug (wontfix)

.show can't make element appear

Reported by: anonymous Owned by:
Priority: low Milestone: 1.next
Component: css Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

Element'll not appear if it's style is "display: none !important";

Test case here: http://jsfiddle.net/uA9aP/

Change History (2)

comment:1 Changed 9 years ago by timmywil

Component: unfiledcss
Keywords: needsdocs added
Priority: undecidedlow
Resolution: wontfix
Status: newclosed

This is intended behavior. !important styles are really important. ;) To override an !important style, do .css('display', 'block !important'). Tagging needsdocs as we should probably state this for fadeIn and show.

comment:2 Changed 8 years ago by addyosmani

Keywords: needsdocs removed
Note: See TracTickets for help on using tickets.