Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8925 closed enhancement (invalid)

Some fix in method call in Null object

Reported by: asnow.dev@… Owned by: asnow.dev@…
Priority: low Milestone: 1.next
Component: unfiled Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

I had some worning error. It's not so dangerouse.

In next code we can take a null parent so null doesn't have a method .parentNode.

var withinElement = function( event ) {

Check if mouse(over|out) are still within the same parent element var parent = event.relatedTarget;

Firefox sometimes assigns relatedTarget a XUL element which we cannot access the parentNode property of try {

Chrome does something similar, the parentNode property can be accessed but is null. if ( parent !== document && !parent.parentNode ) {

return;

}

Change History (2)

comment:1 Changed 9 years ago by addyosmani

Owner: set to asnow.dev@…
Priority: undecidedlow
Status: newpending

Thanks for submitting a ticket to the jQuery Bug Tracker. Please supply us with a valid test case on jsFiddle.net reproducing the behaviour you feel is currently breaking.

comment:2 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.