Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#8920 closed bug (duplicate)

Setting checked attr of checkbox before appended to DOM in IE6-7

Reported by: david@… Owned by:
Priority: high Milestone: 1.next
Component: manipulation Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

Creating a new input with attrs of type:'checkbox' and checked:true then appending to the DOM tree will show a checked checkbox in IE8+, Chrome, Firefox, etc but a unchecked checkbox in IE6-7.

http://jsfiddle.net/fgnSP/1/

Possibly related to http://bugs.jquery.com/ticket/8060.

Change History (2)

comment:1 Changed 9 years ago by timmywil

Component: unfiledmanipulation
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

Yes, it's the same as #8060. Patch is currently under review for 1.6. https://github.com/jquery/jquery/pull/332

comment:2 Changed 9 years ago by timmywil

Duplicate of #8060.

Note: See TracTickets for help on using tickets.