Bug Tracker

Opened 8 years ago

Closed 8 years ago

#8907 closed bug (invalid)

Infinite loop when passing form variable to AJAX from within that form's submit.

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: 1.next
Component: ajax Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

I discovered from accidentally using the wrong variable name that if you pass a form variable to an AJAX request, it infinite loops and explodes. To reproduce with a form with id="formid":

$("#formid").submit(function() {
  $.get("/path/", { "form": formid }, function() {});
  return false;
});

The GET request never gets sent; somehow passing the form as part of the data causes an infinite loop that crashes the page.

Change History (2)

comment:1 Changed 8 years ago by timmywil

Component: unfiledajax
Owner: set to anonymous
Status: newpending

Thanks for taking the time to contribute to the jQuery project!

I created a test case but was unable to reproduce your issue. You may have been getting an error because formid was not in quotes. http://jsfiddle.net/timmywil/mZhya/

Please provide a reduced test case on http://jsFiddle.net that reproduces the issue experienced to help us assess your ticket. You can mock ajax requests using urls like "/echo/html" or "/echo/json". Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.