Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8902 closed bug (duplicate)

jQuery.param regression with empty arrays

Reported by: roborg@… Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

For the following code:

var obj = {'foo[]':[]};
var str = jQuery.param(obj);

In jQuery 1.4.2, str === "" but in jQuery 1.5.2 str === "foo%5B%5D=".

The end result is that in 1.5.2, PHP receives an array with a single element, which is an empty string - this is incorrect.

Change History (3)

comment:1 Changed 8 years ago by anonymous

Sorry - duplicate of #6481

comment:2 Changed 8 years ago by addyosmani

Resolution: duplicate
Status: newclosed

comment:3 Changed 8 years ago by addyosmani

Duplicate of #6481.

Note: See TracTickets for help on using tickets.