Bug Tracker

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#8885 closed bug (duplicate)

triggering checkbox's click()

Reported by: qwertymk Owned by: qwertymk
Priority: undecided Milestone: 1.next
Component: event Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

When I trigger a checkbox's click event. it ends up being the wrong status.

Look at this demo to see what I mean:

http://jsfiddle.net/EpPYk/

Change History (6)

comment:1 Changed 9 years ago by timmywil

Component: unfiledevent
Owner: set to qwertymk
Status: newpending

Works for me. Which browser are you using?

comment:2 Changed 9 years ago by qwertymk

Status: pendingnew

FF and Chrome, the first way should work like the second way.

comment:3 Changed 9 years ago by Rick Waldron

Resolution: worksforme
Status: newclosed

The correct event to bind to is "change"

http://jsfiddle.net/rwaldron/EpPYk/1/

comment:4 Changed 8 years ago by dmethvin

Resolution: worksforme
Status: closedreopened

comment:5 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: reopenedclosed

comment:6 Changed 8 years ago by dmethvin

Duplicate of #3827.

Note: See TracTickets for help on using tickets.