Bug Tracker

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#8880 closed bug (wontfix)

CSS Hook for marginRight causes Flash and Sliverlight to reload in Webkit

Reported by: psayre@… Owned by: timmywil
Priority: low Milestone: 1.next
Component: css Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

When using the Webkit work around on line 5989 (for marginRight), the swap causes both Flash and Silverlight to reload. This happens when you try to get the right margin of a table that has these plugins in it.

Here's a jsFiddle for it. It's missing the plugin because you can't have remove flash or silverlight files. :/ http://jsfiddle.net/S5QKv/2/

The Webkit bug doesn't apply to tables, so I think the fix is to test for a table prior to the swap.

Change History (7)

comment:1 Changed 8 years ago by timmywil

Component: unfiledcss
Owner: set to psayre@…
Status: newpending

Interesting. Do you have a page somewhere that demonstrates the reload?

Thanks!

comment:2 Changed 8 years ago by psayre@…

Status: pendingnew

It looks like the real issue is changing the display for a table in both Firefox and Webkit.

I have a working example: http://rainier.sitecrafting.com/workspace/psayre/sandbox/2011-04-14%20TableInlineBug/

comment:3 Changed 8 years ago by timmywil

Owner: changed from psayre@… to timmywil
Priority: undecidedlow
Status: newassigned

It seems that changing any css on a table containing a swf has this problem. However, I have confirmed that tables do not have the marginRight problem. View in Safari 5: http://jsfiddle.net/timmywil/XaRQ4/

comment:4 Changed 8 years ago by timmywil

Blocked by: 4872 added

comment:5 Changed 8 years ago by dmethvin

Blocked by: 4872 removed

(In #4872) It sounds like we can't fix this inside jQuery in a reasonable way. The first step would be that we need a test case. Can someone provide one?

comment:6 Changed 7 years ago by mikesherov

Resolution: wontfix
Status: assignedclosed

The only browsers still effected by the reliableMarginRight issue is Safari 5.0 and old mobile safari. Mobile Safari does not support Silverlight nor Flash. Safari 5.0 is under 1% of users.

Combine that with Flash inside of a table, and you're in the "dozens of people worldwide" are effected territory.

With that said, I'm resolving as wontfix.

OP or timmywil, please feel free to respond if you think I've made the wrong call here.

comment:7 Changed 7 years ago by Rick Waldron

+1 to the close

Note: See TracTickets for help on using tickets.