Bug Tracker

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#8867 closed bug (invalid)

.load() and <script> tags doesnt work in any IE

Reported by: dreier.christian@… Owned by: dreier.christian@…
Priority: undecided Milestone: 1.next
Component: ajax Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

hi,

im using the load() method, to load a html file into a div

$('#content').load('moreContent.html');

but if the file moreContent.html contains <script> tags, also empty tags(!) no IE version would load my file.

workaround for the moment: putting the code in the callback function.

Change History (2)

comment:1 Changed 9 years ago by timmywil

Component: unfiledajax
Owner: set to dreier.christian@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsFiddle.net that reproduces the issue experienced to help us assess your ticket. You can mock ajax requests and provide the html to return to jsfiddle including script tags.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.