Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8855 closed bug (invalid)

Object Expected Errors in IE for Versions 1.5 and 1.5.2 but not 1.2.6

Reported by: tklem@… Owned by:
Priority: undecided Milestone: 1.next
Component: global Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

Every time I try doing any of the examples in the jQuery API section of Beginning JavaScript and CSS Development in jQuery, they give Object Expected errors in IE 8 and don't function properly if I use versions 1.5 and 1.5.2. They work just fine in Firefox 3, Chrome, Safari, and Opera.

But, if I use version 1.2.6 that comes with the book's website, all the scripts work fine in IE as well as the other browsers.

Here's the book website if that helps.

http://www.wrox.com/WileyCDA/WroxTitle/Beginning-JavaScript-and-CSS-Development-with-jQuery.productCd-0470227796.html

Change History (1)

comment:1 Changed 9 years ago by timmywil

Component: unfiledglobal
Resolution: invalid
Status: newclosed

Those scripts are stale and have not been updated to use 1.5.2. If you could provide a specific jQuery bug with a reduced test case, we can review it. See the Bug Reporting Guidelines. You can find support on the #jquery irc channel or at http://forum.jquery.com/Using_jQuery

Note: See TracTickets for help on using tickets.