Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#8850 closed bug (worksforme)

resize events crashes on firefox 4

Reported by: [email protected] Owned by: [email protected]
Priority: low Milestone: 1.next
Component: event Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

In Firefox 4 calling any function on $(window).resize(), even an alert, crashes the browser

Change History (9)

comment:1 Changed 11 years ago by addyosmani

Owner: set to [email protected]
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsFiddle.net that reproduces the issue experienced to help us assess your ticket!

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 11 years ago by Rick Waldron

Component: unfiledevent
Resolution: worksforme
Status: pendingclosed

Tested in FF 3.6, 4.0, 4.2a1pre

http://jsfiddle.net/rwaldron/PX28a/

comment:3 Changed 11 years ago by originof

For me a simple page like http://pastebin.com/DTpcwLKy crash firefox 4

comment:4 Changed 11 years ago by timmywil

Alerts stop execution, but will still be continually added to the stack on every resize. It is best not to do that. Use console.log for debugging. http://fixingthesejquery.com/#slide3

comment:5 in reply to:  4 Changed 11 years ago by [email protected]

Actually, alert in a resize event crashes firefox 4 (probably due to the new alert window in js). console.log or whatever else function work correctly,

comment:6 Changed 10 years ago by anonymous

Yes, this is the case. It's a firefox bug.

comment:7 Changed 10 years ago by Rick Waldron

Priority: undecidedlow

comment:8 Changed 10 years ago by anonymous

Same issue here. Alert on $(window).resize() causes freeze up.

comment:9 Changed 9 years ago by [email protected]

Same issues on FF19 on $(window).resize() causes freeze up.

Note: See TracTickets for help on using tickets.