Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8824 closed bug (invalid)

Selector is now unrecognized

Reported by: abel.tamayo@… Owned by: abel.tamayo@…
Priority: undecided Milestone: 1.next
Component: selector Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have found this error in Firefox 3.6 under Ubuntu:

using jQuery 1.4.2 this selector works: jQuery('select[name=[time]]') but after updating to jQuery 1.5.2 it rises the following error: uncaught exception: Syntax error, unrecognized expression: [name=[time]]

I'm pretty sure it's jQuery's version the only problem here because if I switch back to 1.4.2 it works again.

Hope this helps.

Change History (2)

comment:1 Changed 9 years ago by addyosmani

Owner: set to abel.tamayo@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsFiddle.net that reproduces the issue experienced to help us assess your ticket!

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 9 years ago by timmywil

Component: unfiledselector
Resolution: invalid
Status: pendingclosed

Even though it worked in jQuery 1.4.2, that is an invalid selector. This has been fixed in jQuery 1.5. Use quotes instead of brackets to check the value of an attribute: http://api.jquery.com/attribute-equals-selector/

Last edited 9 years ago by timmywil (previous) (diff)
Note: See TracTickets for help on using tickets.