Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8823 closed bug (invalid)

parseJSON Chrome

Reported by: [email protected] Owned by: [email protected]
Priority: undecided Milestone: 1.next
Component: ajax Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hello,

On Chrome, window.JSON.parse fails for:

'{a:"x[TAB]y"}' where [TAB] is the ASCII character 9

The jQuery parseJSON has the comment: Try to use the native JSON parser first

but it does not try, it just tests if window.JSON.parse is available.

Why not try, and when it fails try the alternate (new Function("return " + data))() ?

Vianney Hully

Change History (4)

comment:1 Changed 11 years ago by addyosmani

Owner: set to [email protected]
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsFiddle.net that reproduces the issue experienced to help us assess your ticket!

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 11 years ago by timmywil

Component: unfiledajax

comment:3 Changed 11 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:4 Changed 11 years ago by [email protected]

In the last Chrome version - 11.0.696.57 -, the JSON.parse is fixed so both $.parseJSON( '{"a":"x y"}' ) and JSON.parse( {"a":"x y"}' ) work fine.

The ticket can be closed.

Note: See TracTickets for help on using tickets.