Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8817 closed bug (invalid)

Status of XMLHttpRequest object is not set to 0 (If any ajax request is aborted) in IE 9

Reported by: Rahul Owned by: Rahul
Priority: undecided Milestone: 1.next
Component: ajax Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

According to my requirement if i have more that 1 ajax request at a time then i am aborting the first one and processing latest request. Aborted ajax request gives XHRobject.status value to 0 in all browser( as expected) But in IE 9 it not working. I have attached a sample code.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
	<head>
	<title>Test</title>
        <script type="text/javascript" src="/jquery.js"></script>
        <script type="text/javascript">
        $(document).ready(function(){
            var xhr = null;
            $('#sendReq').click(function(){
            if(xhr && xhr.readystate != 4){
                xhr.abort();
            }

            xhr = $.ajax({
			type : 'POST',
			url : '/p.php',
			dataType : 'html',

			success : function(data){
				$('#data').append(data);

			},
			error : function(XMLHttpRequest, textStatus, errorThrown) {
				$('#errorStatus').append(xhr.status);
			}
		});
                
        });
        });
        </script>
	</head>
	<body>        
			
            <h3>sends ajax request</h3>
            <button id="sendReq">
                send
            </button>
            <div id="data">

            </div>

            <div id="errorStatus">

            </div>
	
	</body>
</html>

Change History (2)

comment:1 Changed 9 years ago by timmywil

Component: unfiledajax
Owner: set to Rahul
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsFiddle.net that reproduces the issue experienced to help us assess your ticket. You can mock ajax requests using their specified urls. Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.