Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8780 closed bug (invalid)

events, preventDefault

Reported by: PatrickS Owned by: PatrickS
Priority: undecided Milestone: 1.next
Component: event Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

Hi to the bug tracking team,

Trying to debug $(document).onkeypress() handler, I found a way to make my script working as expected... yupee! but finalizing / cleaning the source file, I mentioned that I wrote "e..preventDefault()" (yes, two points). I thought first that it was a language feature I ignored, like "/" in Unix path root! Correction -> it stopped working! Back to "..": it worked! Too strange, try with Opera and you guess the result. So ?  Do I have to send a bug report to Mozilla ? Finally, I always had difficulties with events handlers... Now I have doubts on Firefoxe.

Mozilla/5.0 (X11; U; Linux i686 (x86_64); fr; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16

Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0) Gecko/20100101 Firefox/4.0

I was working first with jQuery 1.4.4. then passed to version 1.5.2

THE "e..preventDefault()" CALL IS WORKING ON BOTH VERSION OF FIREFOX TRYED

Thanks for the nice job you've done. Patrick

Change History (5)

comment:1 Changed 9 years ago by timmywil

Owner: set to PatrickS
Status: newpending

Please provide a test case on http://jsfiddle.net and explain your issue in plain English or some language we might be able to translate. onkeypress is keypress in jQuery and e..preventDefault is invalid javascript syntax.

comment:2 in reply to:  1 Changed 9 years ago by PatrickS

Status: pendingnew

Replying to tinywil:

in plain English

Je crois qu'il aurait été bien plus convenable de dire que mon explication est incompréhensible. Mais bon: la bonne éducation n'est probablement pas anglo-saxonne.

or some language we might be able to translate.

Voilà qui est fait. En conclusion, j'accepte volontiers vos remerciements pour mon apport. Vous comprendrez, si vous avez cette possibilité, que je n'irai rien déposer sur jsFiddle.

comment:3 Changed 9 years ago by timmywil

Status: newpending

Yes I understand and I didn't mean to be inappropriate. Incomprehensible is a better word to use. More information would be very helpful as we cannot understand what the issue is for this ticket. A test case on http://jsfiddle.net would clear things up for us. Thank you again!

comment:4 Changed 9 years ago by anonymous

See Bugzilla@Mozilla – Bug 648696 https://bugzilla.mozilla.org/show_bug.cgi?id=648696

comment:5 Changed 9 years ago by Rick Waldron

Component: unfiledevent
Resolution: invalid
Status: pendingclosed

This is not a jQuery bug; It's a valid error triggered by Firefox's E4X implementation. http://en.wikipedia.org/wiki/E4X

reduced test case: http://jsfiddle.net/rwaldron/BNzXP/

Note: See TracTickets for help on using tickets.