Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#8779 closed bug (invalid)

IE9: 'Date' is undefined in jquery.js

Reported by: ewuch@… Owned by: ewuch@…
Priority: low Milestone: 1.next
Component: core Version: 1.5.2
Keywords: ie9 Cc:
Blocked by: Blocking:

Description

I'd read much about how jQuery 1.5.1 is supposed to be compatible with IE9. However, when testing it, I get a bug that 'Date' is undefined in jquery.js (line 811). I tried 1.5.2 and the same thing happens (line 805 of jquery.js). Will jQuery be compatible with IE9 at some point?

Change History (8)

comment:1 Changed 9 years ago by timmywil

Keywords: ie9 added
Owner: set to ewuch@…
Status: newpending

Thank you for filing a report on the jQuery bug tracker! I'm not sure to what you're referring. Please provide a test case on http://jsfiddle.net that reproduces your issue so we can confirm that this is an issue with jQuery.

comment:2 Changed 9 years ago by Rick Waldron

Component: unfiledcore

This reads like an IE9 bug, not a jQuery bug. Date() is standard.

comment:3 Changed 9 years ago by ewuch@…

Status: pendingnew

It turns out the bug seems to have occurred from more of a race condition that had not come up other than in IE9. There was a $(document).ready(...) which ultimately resulted in the document getting removed, but this would happen before jQuery.ready(), so the document would be gone when that was called. Apparently the first thing to go wrong would be Date no longer being defined, hence that error. Changing it to a $(window).load(...) solved the problem.

comment:4 Changed 9 years ago by timmywil

Resolution: invalid
Status: newclosed

Sounds good. Thanks for looking into it.

comment:5 in reply to:  description Changed 8 years ago by anonymous

Replying to ewuch@…:

I'd read much about how jQuery 1.5.1 is supposed to be compatible with IE9. However, when testing it, I get a bug that 'Date' is undefined in jquery.js (line 811). I tried 1.5.2 and the same thing happens (line 805 of jquery.js). Will jQuery be compatible with IE9 at some point?

I have same problem :(

comment:6 Changed 8 years ago by timmywil

Priority: undecidedlow

There has not yet been a test case provided, which makes it difficult to reproduce any issue with IE9. Date is a regular javascript constructor that has nothing to do with jQuery.

comment:7 Changed 7 years ago by robert@…

Having the same issue it happens only in IE 9 when I try to remove a frame that has a document.ready inside the frame.

If I remove the document.ready functions from the iframe source it works.

If I create a simple example doing the same thing in jsfiddle it works the program I am working in is huge so I am not sure what in my program causes the issue.

My way around it was to set the source of the frame to "about: blank" and then removing the frame after the blank page loads. I only have to do this in IE.

Weird issue because the error does not seem to relate to the issue.

comment:8 Changed 6 years ago by anonymous

I have it too. Seems related to this problem http://stackoverflow.com/questions/9695099/date-is-undefined-in-ie9-in-javascript-loaded-by-facepile that seems to be caused by an IE bug that it might execute script before it's added to the DOm, hence before it has access to standard JavaScript such as Date. http://www.guypo.com/technical/ies-premature-execution-problem/ describes it.

Note: See TracTickets for help on using tickets.