Bug Tracker

Opened 9 years ago

Closed 7 years ago

#8768 closed bug (fixed)

Chunker has problems with single quote in attribute filter

Reported by: orslumen@… Owned by: timmywil
Priority: high Milestone: 1.next
Component: selector Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hello,

When a Browser does not support querySelectorAll (e.g. EnvJs headless browser), the "old" Sizzle implementation is used.

With that Sizzle implementation the selector jQuery(':button[title="Don\'t Save"]') fails. The exception is: Syntax error, unrecognized expression: Save"]

It seems like the Chunker doesn't like the single quote within the attribute filter.

Note that when querySelectorAll is available (e.g. in FireFox 3.6) the selector works fine.

Change History (11)

comment:1 Changed 9 years ago by Rick Waldron

Component: unfiledselector
Owner: set to orslumen@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket!

Additionally, test against the jQuery Edge version to ensure the issue still exists.

comment:2 Changed 9 years ago by anonymous

Ok, here it is: http://jsfiddle.net/W36Av/

Please note that you need a browser that does not support *querySelectorAll* (IE 6, IE 7, FF 3.0) to reproduce the error.

comment:3 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:4 Changed 9 years ago by anonymous

Obviously I was not aware of the correct WF in this tracker. I replied promptly to the question asked two weeks ago, but should have also manually changed the status(?).

Anyways, the bug is still there, so I guess it would be best to reopen this ticket.

comment:5 Changed 9 years ago by timmywil

Priority: undecidedhigh
Resolution: invalid
Status: closedreopened

Looks like you opened the ticket as orsiumen and posted the fiddle as anonymous so the tracker didn't think you responded. Reopening. Agree that the escaped quote may be the issue.

comment:6 Changed 9 years ago by timmywil

Status: reopenedopen

comment:7 Changed 9 years ago by Orslumen <orslumen@…>

Aha, I see. Saved my email address as a preference. Next time I won't forget ;)

comment:8 Changed 8 years ago by john

Confirmed in bug triage.

comment:9 Changed 7 years ago by timmywil

Confirmed in 1.8beta

comment:10 Changed 7 years ago by timmywil

Owner: changed from orslumen@… to timmywil
Status: openassigned

comment:11 Changed 7 years ago by timmywil

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.