Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8758 closed bug (duplicate)

Finding element with autofocus attribute doesn’t work always

Reported by: taimar Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

attribute: autofocus
selector: :input[autofocus]
demo: http://jsfiddle.net/nk4bn/
wrong result: FF3.6, FF3.5, IE6-IE9

attribute: autofocus
selector: input[autofocus]
demo: http://jsfiddle.net/nk4bn/1/
wrong result: IE6, IE7

attribute: autofocus="autofocus"
selector: :input[autofocus]
demo: http://jsfiddle.net/nk4bn/2/
wrong result: none

attribute: autofocus="autofocus"
selector: input[autofocus]
demo: http://jsfiddle.net/nk4bn/3/
wrong result: none

jQuery doesn’t like/understand HTML5 boolean attributes?
http://dev.w3.org/html5/spec/Overview.html#boolean-attribute

Change History (2)

comment:1 Changed 8 years ago by timmywil

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by timmywil

Duplicate of #5637.

Note: See TracTickets for help on using tickets.