Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8740 closed bug (duplicate)

Has Attribute Selector fails on empty attributes on ie6/ie7/ff3.0

Reported by: gabor@… Owned by:
Priority: high Milestone: 1.next
Component: selector Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

when i have an element with an attribute without a value, the has-attribute-selector in jquery should match that element. it works on newer browsers, but it does not work on internet explorer 6, internet explorer 7 and on firefox 3.0.

example:

<div data-thing="">text</div>
<script>alert($('div[data-thing]').length);</script>

(also on jsfiddle: http://jsfiddle.net/pNjwe/2/)

it shows 1 on newer browsers, and 0 on the mentioned browsers.

Change History (3)

comment:1 Changed 8 years ago by timmywil

Component: unfiledselector
Priority: undecidedhigh
Status: newopen
Version: 1.5.11.5.2

comment:2 Changed 8 years ago by timmywil

Resolution: duplicate
Status: openclosed

comment:3 Changed 8 years ago by timmywil

Duplicate of #7128.

Note: See TracTickets for help on using tickets.