Bug Tracker

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#874 closed bug (fixed)

$(html) fails when html contains ' '

Reported by: Arrix Owned by:
Priority: major Milestone:
Component: core Version: 1.1
Keywords: Cc:
Blocked by: Blocking:

Description

$('<p> </p>') fails (and freezes my Firefox 2.0.0.1).

This happens when the html string contains ' '.

The problems is caused by the html extraction line in function jQuery.

var m = /^[^<]*(<(.|
)+>)[^>]*$/.exec(a);

which fails with ' '.

/^[^<]*(<(.|s)+>)[^>]*$/ works for me.

Change History (1)

comment:1 Changed 13 years ago by joern

Resolution: fixed
Status: newclosed

Fixed in revision 1242.

Note: See TracTickets for help on using tickets.