Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#8737 closed bug (duplicate)

Window Unload Event Error on IE 7/8, maybe 6

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.5.2rc1
Keywords: Cc:
Blocked by: Blocking:

Description

The new jquery version 1.5.2 produces a javascript error on using the window unload event on IE7/8, maybe 6...

'type' is null or not an object

Change History (5)

comment:1 Changed 9 years ago by dmethvin

Owner: set to anonymous
Status: newpending

Please provide a test case in jsFiddle.

comment:2 in reply to:  1 Changed 9 years ago by anonymous

Status: pendingnew

That is ridiculous... I already mentioned how to reproduce the error!? why do you need jsFiddle... there are many other people complaining about this same issue on other tickets... so maybe you should stop making excuses and fix the bug

comment:3 in reply to:  1 Changed 9 years ago by anonymous

Really, how long does it take to open a web browser and create a test.js file to reproduce the issue? a few minutes

comment:4 Changed 9 years ago by ajpiano

Resolution: duplicate
Status: newclosed

It takes about as long as it takes to leave incendiary comments insulting the motives of a team of volunteers who are just trying to keep things organised. I've created testcases and linked them to the reopened ticket 8755, which documents the same issue. The reason this ticket is "8737" is because there have been over eight thousand, seven hundred tickets filed on jQuery Core over time. We need testcases because that is a BIG NUMBER and tickets with "instructions" don't necessarily lead to us creating the same circumstances as the OP. In this case, it seems to be a legit bug, and I wanted to get a testcase done so we can move on to fixing it, but in general, trying to insult people into helping is rarely a good strategy. Thanks for your time and interest in helping out with the project!

comment:5 Changed 9 years ago by ajpiano

Duplicate of #8755.

Note: See TracTickets for help on using tickets.