Bug Tracker

Opened 8 years ago

Closed 8 years ago

#8730 closed bug (worksforme)

Chrome 10 & 12(nightly) report different values for position()

Reported by: geuis.teses@… Owned by: geuis.teses@…
Priority: low Milestone: 1.next
Component: offset Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have a div that is 940px wide and is centered using margin:0 auto;

In Chrome 10.1.648.204, $('#mydiv').position() reports 0,0 for left and top respectively. In Chrome 12.0.712.0 (nightly) reports values (490,0) for the same div using $('#mydiv').position().

Change History (4)

comment:1 Changed 8 years ago by timmywil

Owner: set to geuis.teses@…
Status: newpending

Thank you for submitting a bug report to the jQuery project! Please provide a test case on http://jsfiddle.net that reproduces your issue.

comment:2 Changed 8 years ago by timmywil

Also, Chrome nightly is not supported until it's official release, but Rick Waldron said he would review your issue if you could provide a test case.

comment:3 Changed 8 years ago by timmywil

Component: unfiledoffset
Keywords: webkit firefox position added
Status: pendingopen
Version: 1.5.11.5.2

http://jsfiddle.net/FFRsx/2/ Thanks to adamjmcintyre for providing a test case. It seems the problem is in Chrome 10 and Firefox 3.6. IE6-8 and F4 show different results.

comment:4 Changed 8 years ago by Rick Waldron

Keywords: webkit firefox position removed
Priority: undecidedlow
Resolution: worksforme
Status: openclosed

This appears to be resolved.

Note: See TracTickets for help on using tickets.