Bug Tracker

Opened 8 years ago

Closed 8 years ago

#8690 closed bug (worksforme)

Selenium mouseover event doesn't work in jquery 1.5.1

Reported by: dimas7 Owned by: dimas7
Priority: undecided Milestone: 1.next
Component: event Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

Selenium server 2.0b3 + jquery 1.5.1 no errors in logs, but doesn't work as expected - no pop-up shown (the same code worked with prev. version of jquery)

14:47:21.978 DEBUG - REQUEST from SocketListener0@0.0.0.0:4444: GET /selenium-server/driver/?cmd=mouseOver&1=%2F%2Fa%5Bcontains%28%40id%2C%22use rLink_777%22%29%5D&sessionId=51331bbcb6e34713a2d93d680268f038 HTTP/1.1 TE: deflate,gzip;q=0.3 Connection: TE Host: 192.168.1.248:4444 User-Agent: libwww-perl/5.812

14:47:21.978 DEBUG - Try HttpContext[/selenium-server/driver,/selenium-server/dr iver],0 14:47:21.978 DEBUG - Try HttpContextselenium-server,/selenium-server,0 14:47:21.978 DEBUG - Handler org.openqa.jetty.http.handler.SecurityHandler in Ht tpContextselenium-server,/selenium-server 14:47:21.978 DEBUG - Handler org.openqa.selenium.server.StaticContentHandler in HttpContextselenium-server,/selenium-server 14:47:21.978 DEBUG - PATH=/driver/ RESOURCE=file:/C:/Documents%20and%20Settings/ user/¦рсюўшщ%20ёЄюы/MISSING%20RESOURCE 14:47:21.978 DEBUG - Looking for file:/C:/Documents%20and%20Settings/user/¦рсюўш щ%20ёЄюы/MISSING%20RESOURCE 14:47:21.978 DEBUG - Handler org.openqa.selenium.server.SessionExtensionJsHandle r in HttpContextselenium-server,/selenium-server 14:47:21.978 DEBUG - Handler org.openqa.selenium.server.htmlrunner.SingleTestSui teResourceHandler in HttpContextselenium-server,/selenium-server 14:47:21.978 DEBUG - Handler org.openqa.selenium.server.htmlrunner.SeleniumHTMLR unnerResultsHandler@a3bcc1 14:47:21.978 DEBUG - Handler org.openqa.selenium.server.CachedContentTestHandler @1891d8f 14:47:21.993 DEBUG - Handler org.openqa.selenium.server.SeleniumDriverResourceHa ndler in HttpContextselenium-server,/selenium-server 14:47:21.993 DEBUG - req: GET /selenium-server/driver/?cmd=mouseOver&1=%2F%2Fa%5 Bcontains%28%40id%2C%22userLink_777%22%29%5D&sessionId=51331bbcb6e34713a2d93d680 268f038 HTTP/1.1 TE: deflate,gzip;q=0.3 Connection: TE Host: 192.168.1.248:4444 User-Agent: libwww-perl/5.812

14:47:21.993 INFO - Command request: mouseOvera[contains(@id,"userLink_777") , ] on session 51331bbcb6e34713a2d93d680268f038 14:47:21.993 DEBUG - Executing 'mouseOver' selenium core command on session 5133 1bbcb6e34713a2d93d680268f038 14:47:21.993 DEBUG - Session 51331bbcb6e34713a2d93d680268f038 going to doCommand (mouseOver,a[contains(@id,"userLink_777")],) 14:47:21.993 DEBUG - ---------retrieving CommandQueue for sel_97052 14:47:21.993 DEBUG - sel_97052 commandHolder sel_97052 getCommand() 14:47:21.993 DEBUG - putting command: json={command:"mouseOver",target:"a[cont ains(@id,\"userLink_777\")]",value:""} 14:47:21.993 DEBUG - ..command put?: true 14:47:21.993 DEBUG - data from polling: json={command:"mouseOver",target:"a[co ntains(@id,\"userLink_777\")]",value:""} 14:47:21.993 DEBUG - sel_97052 commandResultHolder sel_97052 getResult() call ed 14:47:21.993 DEBUG - sel_97052 commandHolder sel_97052 getCommand() -> json={ command:"mouseOver",target:"//a[contains(@id,\"userLink_777\")]",value:""} 14:47:21.993 DEBUG - waiting for data for at most 1800 more s 14:47:21.993 DEBUG - res to sel_97052: json={command:"mouseOver",target:"a[con tains(@id,\"userLink_777\")]",value:""} 14:47:21.993 DEBUG - Handled by org.openqa.selenium.server.SeleniumDriverResourc eHandler in HttpContextselenium-server,/selenium-server 14:47:21.993 DEBUG - RESPONSE: HTTP/1.1 200 OK Date: Tue, 29 Mar 2011 10:47:21 GMT Server: Jetty/5.1.x (Windows XP/5.1 x86 java/1.6.0_24 Cache-Control: no-cache Pragma: no-cache Expires: Thu, 01 Jan 1970 00:00:00 GMT Content-Type: text/plain Content-Length: 1080

Change History (3)

comment:1 Changed 8 years ago by dmethvin

Owner: set to dimas7
Status: newpending

A log dump doesn't help in debugging this. Please provide a test case. Does it work with 1.5.2?

comment:2 Changed 8 years ago by dimas7

Status: pendingnew

I checked the same test case in 1.5.2 and it works fine. So I think the problem is solved. Thanks:)

comment:3 Changed 8 years ago by Rick Waldron

Component: unfiledevent
Resolution: worksforme
Status: newclosed

Closing, per latest comment

Note: See TracTickets for help on using tickets.