Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8687 closed bug (duplicate)

improperly coded JSON string for empty array or object

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: 1.next
Component: ajax Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

When the data element of an ajax query includes either an empty object or empty array the buildParams function is improperly coding the value as nothing. Proper JSON coding for an empty array is '[]' and an empty object should be '{}'

I've checked the 1.5.1 source (line 6840) as well as 1.4.3 (line 5858.) Both exhibit this bug.

Change History (3)

comment:1 Changed 8 years ago by Rick Waldron

Component: unfiledajax
Owner: set to anonymous
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket!

Additionally, test against the jQuery 0 GIT version to ensure the issue still exists. Be Excellent to eachother!

comment:2 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: pendingclosed

comment:3 Changed 8 years ago by dmethvin

Duplicate of #6481.

Note: See TracTickets for help on using tickets.